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How to install AT2Sage 

AT2Sage should be installed on the same computer as your Sage Accounts 50 software is installed. 

Visit http://www.smartitsoftware.co.uk to install AT2Sage. 

Technical Requirements 
AT2Sage is compatible with Microsoft Windows 2000, Windows XP, Windows 2003, Windows Vista, 

Windows 2008, Windows 7 and Windows 8. 

AT2Sage supports Sage Line 50 Accounts version 8 to 20, this includes Sage Accounts 2014 

You can run AT2Sage without using the Send To Sage functionality.  However, AT2Sage does require 

Sage’s SDO (Sage Data Objects) Engine to be installed and enabled in order to send invoices to Sage 

Accounts.   

The SDO is automatically installed when you install Sage Accounts but needs a special Serial Number 

and Activation Key before it can be used. These details can be entered from within Sage Accounts by 

going to "Tools / Activation / Enable 3rd Party Integration". To obtain these details phone Sage on 

0845 111 6666 and tell them that you want a Serial Number and Activation Key to enable 3rd party 

integration. Currently Sage does not charge for providing these details. 

Ideally AT2Sage should be installed on the same PC as your Sage Accounts program is installed. 

  

http://www.smartitsoftware.co.uk/
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Configuration 

Once installed launch AT2Sage using the AT2Sage icon on the desktop. 

When you first open AT2Sage you will need to enter your Sage Accounts and Autotask credentials. 

To do this go to Tools, then Options and enter your credentials.  Click Test Connection to verify 

AT2Sage can connect to your accounts. 

General Options 

 

 Include Ticket Title in Product 

Ticking this option will display the ticket title in the product description on the invoice 

 Include Ticket Title in Labour 

Ticking this option will display the ticket title in the service description on the invoice 

 Include Ticket Number 

Ticking this option will display the ticket number in the product/service description on the 

invoice 

 Include Summary Notes 

Ticking this option will display the summary notes in the service description on the invoice 

 Include Contract Title 

Ticking this option will display the contract title in recurring services line items on the invoice 

 Group Recurring Services 

Ticking this option will group all service items in a group to appear as one charge.  Any service 

items with an asterisk in the name will not be grouped 

 Group Labour Items on Tickets 
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Ticking this option will group all the time entries on a ticket to give one labour item.  It is not 

possible to include the summary notes on labour items when using this option. 

 Line Items Should Be… 

o Let AT2Sage Choose. AT2Sage will use a mixed of non-stock and service items for 

products and services in Sage Accounts, based upon what AT2Sage feels best. 

o Service Item.  AT2Sage will create all products within Sage Accounts as service 

items 

o Stock Item.  AT2Sage will create all products within Sage Accounts as stock items. 

o Non-Stock Item.  AT2Sage will create all products within Sage Accounts as non-

stock items. 

 

 Autotask Field to use for Product Code 

AT2Sage can use either the Material Cost Code or Product Code from the product in Autotask as 

the Product Code in Sage.  AT2Sage will remove any spaces or special characters from the code. 
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Sage Options 

   

 Data Path 

This is the path to your Sage Accounts database, the path can vary between Sage versions.  You 

can find the path to your database by opening Sage Accounts and going to Help > About > 

System Information > Directories > Data Directory. 

 Username 

The username to log into Sage Accounts.  It is recommended that you create a new user only to 

be used by AT2Sage. 

 Password 

The password for the username above. 

 Create any missing customers 

AT2Sage finds customers in Sage Accounts by matching up the Account Code in Sage Accounts 

with the Account Number in Autotask. If AT2Sage cannot find the account in Sage by matching 

these values AT2Sage will automatically create a new account in Sage  

 Update Sage Customers 

AT2Sage will update customer accounts in Sage with any changes from Autotask, this includes 

Name, Address, Website Address, and telephone. 

 Mark Terms as Agreed 

When creating or updating Sage customers AT2Sage will mark the Terms as Agreed in Sage. 

 Insert Account Owners Name into Analysis 1 

Ticking this option will insert the Account Owners First Name as set in Autotask for that Account, 

into the Analysis 1 field in Sage.  Many companies use this field to store the Account Owners 

name to allow them to produce reports for a particular Account Owner. 

  Invoice Numbers 
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o Use Autotask Invoice Numbers.  AT2Sage will use the invoice number 

generated within Autotask for the invoice number of the invoice sent to Sage 

Accounts.  Be careful you do not create invoices with the same invoice number. 

o Use Sage Invoice Numbers.  Invoices created within Sage Accounts will use an 

automatically generated invoice number from Sage Accounts. 

o Save Them Back To Autotask.  Invoice numbers generated by Sage Accounts will 

be saved back to Autotask so both the invoice within Autotask and Sage Accounts 

have matching invoice numbers.  This will not affect the invoice ID within 

Autotask. 

 Tax Code 

o Accounts Default Tax Code.  AT2Sage will use the default tax code for the 

account, for all line items on an invoice, regardless of the default tax code setup 

for that particular product 

o Products Default Tax Code.  AT2Sage will use the default tax code setup for the 

product in Sage for the invoice, regardless of the default tax code for that 

account. 
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Autotask Options 

 

 API URL 

This is the URL AT2Sage should use for accessing Autotask.  Autotask may from time to time 

release a new API URL, it is recommended you use the latest API URL. 

 Username 

This is the username AT2Sage should use to access Autotask 

 Password 

This is the Password used for the Autotask account above 

 Download invoices marked as invoiced 

AT2Sage marks invoices sent to Sage as invoiced on Autotask, when this option is un-ticked 

AT2Sage will not download those invoices that have been marked as sent to Sage.  Ticking this 

box will download all invoices including those that have already been sent to Sage. 

 Use Invoice Date from Autotask 

Invoices Dates will be taken from the invoice date within Autotask for all invoices sent to Sage 

Accounts, if this option is not ticked the invoice dates on the invoices will be the date in the top 

right hand corner of AT2Sage main window as below; 
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Email Options 

 

 Display Report after Send To Sage 

Ticking this option will display an HTML report in your default web browser showing details of 

any new customers and invoices created in Sage. 

 Email report after sending invoices to Sage 

Ticking this option will send an email to the specified email address with a report of all the new 

customers and invoices created in Sage. 

 Email To 

This is the Email address AT2Sage will send the email report to 

 Email From 

This is the email address the email will appear to have come from 

 SMTP Server 

The address of the SMTP server to use to send the email 

 Port 

The SMTP port to use to send the email 

 Requires Authentication 

Tick if the SMTP requires authentication to send emails 

 Username 

The username to use to authenticate against the SMTP server 

 Password 

The password for the username above 
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Nominal Codes 

 

AT2Sage allows you to setup Nominal Codes for different Allocation Codes, for example you may 

want Bench Work to use Nominal Code 4001 and Onsite Support to use Nominal Code 4002.  This 

allows you to create more detailed reports in Sage Accounts.  

Although you can also create these Nominal Codes in Autotask, the current Autotask API does not 

allow AT2Sage to download these Nominal Codes.  Therefore if you want AT2Sage to use Nominal 

Codes they must be setup in AT2Sage. 

The Default Nominal Code is used for the Nominal Code of items that do not have a Nominal Code 

setup in the list above. 
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Downloading Invoices 

When you’ve successfully tested your connections you can 

now start to process invoices.   

To download your Autotask invoices click the Download 

Invoices button.  You will be presented with a dialog similar 

to that on the right. 

Choose the date range you would like to download invoices 

between (the date applies to the date the invoice was 

created in Autotask).  AT2Sage will download every invoice 

created between these dates that have not already been 

invoiced by AT2Sage – providing you allowed AT2Sage to 

update Autotask with invoices raised (more on this later).  

Once the invoices have been downloaded from Autotask they should appear in a list in the main 

window, like this: 
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Import CSV 

An alternative to directly downloading invoices from Autotask is to import a CSV file that was 

exported from Autotask.   

First export a CSV file from Autotask as follows: 

1. In Autotask go to Contracts > Export Wizard 

2. Choose the dates of the invoices you would like to export and click next. 

3. Select all the charges you would like to export and click next 

4. In the Export Type select CSV (Comma Separated Values) and click next 

5. Tick the box 'Yes, I would like the Field Names in the First Row', click next 

6. Enter a Batch Export Reference Number if you wish, click Finish and wait for a box to pop up 

asking you to save the file. 

7. Save the file somewhere on your computer 

Next is the easy part.  To import your invoices into Autotask click the Import CSV button, select your 

CSV file and click Open.  Your invoices should now appear in the main window. 
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Send Invoices to Sage 

To send your invoices to Sage Accounts 50 simply click the Send To Sage button. 

AT2Sage locates accounts in Sage Accounts 50 by matching the Account Code in Sage Accounts with 

the Account Number in Autotask.  If AT2Sage cannot find a customer with matching Account 

Numbers it will prompt the user with a dialog like below: 

 

This could happen for one of two reasons.   

1. The account does not exist in Sage Accounts;  

In this case select the first option ‘Create a new account’ and enter an Account Code.  

AT2Sage will recommend a code for you but you can use your own if you prefer.  If you 

would like AT2Sage to save the Account Code to Autotask (to prevent AT2Sage asking the 

next time) tick the box ‘Update Autotask with Sage Account Code’ and click OK. 

2. The account exists but Account Numbers do not match 

In this case select ‘Match to this account’ and choose the Sage account from the drop down 

list.  If you would like AT2Sage to save the Account Code to Autotask (to prevent AT2Sage 

asking the next time) tick the box ‘Update Autotask with Sage Account Code’ and click OK. 

Once all the invoices have been sent to Sage Accounts, AT2Sage will ask if you would like to update 

Autotask with a message box like below: 

 

It’s a good idea to click Yes here, this will prevent AT2Sage from downloading the same invoice again 

and sending it twice to Sage Accounts.  If you click Yes AT2Sage will also save the Sage Invoice 

number to Autotask. 
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Export CSV 

You can also export invoices as a CSV file for use in another program, or for processing at a later 

date. 

To Export invoices as a CSV click Export CSV and save the CSV file to your computer. 
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Edit Invoice 

  

Before sending your invoices to Sage Accounts, or exporting them, you can edit an invoice by 

pressing F2 or right clicking that invoice in the list and selecting Edit Invoice.  This will display the 

Invoice Details window above. 

Here you can change the company details and edit or delete charges by right clicking that charge. 

You can also select another Sage account to use by clicking the button beside Account Number. 

Once finished click OK to save the changes, or Cancel to cancel out without saving any changes. 
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Credit Notes 

Autotask can produce invoices with negative line items, this could be to represent a credit for the 

cancellation of a service or an adjustment of a subscription.  While these negative values show 

without any issue on the Autotask invoice, Sage Accounts does not like these values.  Sage Accounts 

prefers all credit/negative value lines to appear on a credit note, and charges to appear on an 

invoice. 

AT2Sage handles this by removing any negative values from the invoice and creating a separate 

credit note for those items.  This could mean that one invoice from Autotask is sent to Sage Accounts 

as one invoice and one credit note. 

AT2Sage relies on Sage Accounts to produce the credit note number, Sage will produce this by 

selecting the next consecutive number from the value stored in:  

Sage Accounts > Settings > Invoice and Order Defaults > Options > Credits start from 

While for most users this will not cause a problem, users who select to use Autotask invoice 

numbers for invoices should be aware that the number Sage Accounts produces for the credit note 

may clash with an invoice number you produce in Autotask. 

To reduce the risk of a clash we recommend that you change the value in the ‘Credits start from’ box 

to be a number that is far out the range that you use for your Autotask invoice numbers. 

Alternatively using Sage generated invoice numbers for invoices and credits will remove the risk of a 

duplicate invoice number being used, you can set this by going to: 

AT2Sage > Tools > Options > Sage > Use Sage Invoice Numbers 
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Appendix 

Sage Data Paths 
This is easily found by going to Help>About>System Information>Directories>Data Directory 

However, if you cannot open Sage 50 it can still be found. 

The location depends on MANY factors, the Version of Sage 50 and the Operating system being the 

two key factors, however, in addition to this data can be located in a custom location! 

Fortunately there is a way to locate your data via the "company" file. 

It is possible to have multiple installations and multiple "company" files on your system. 

Version 13 (2007) or Below 

Right click on one of the Icons used to Launch Sage 50 and choose properties. 

This will tell you where the Program is installed in the "Start in" box; the most common location is 

"C:\Program Files\Sage\Accounts".  However, older versions and installations upgraded from older 

versions can have different paths, so can installations that have been deliberately installed into a 

nonstandard directory. 

Open the location you have discovered, here you will find a file called "Company" it has no file 

extension so has no icon associated with it and looks "strange" 

Double click it - You will be asked what application you want to use to open the file, (the exact 

dialogue varies from operating system to operating system - but you should be able to work it out) 

choose NOTEPAD do not choose anything else. 

When the file opens you will find it contains one or more lines of text giving the path(s) to your 

dataset(s) 

You have successfully located the path to your dataset. 

Version 14 (2008) or Above Windows 95/98/ME/NT/2000/XP 

Open "My Computer" and unhide hidden folders by going to Tools>Folder Options>View>Hidden 

Files and Folders>Show hidden files and folders>OK 

Next go into your C: > Documents and Settings > All Users > Application Data > Sage > Accounts > 

(The year number of your version e.g. 2009 for V15)  

Here you will find a file called "Company" it has no file extension so has no icon associated with it 

and looks "strange" 

Double click it - You will be asked what application you want to use to open the file, (the exact 

dialogue varies from operating system to operating system - but you should be able to work it out) 

choose NOTEPAD do not choose anything else. 
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When the file opens you will find it contains one or more lines of text giving the path(s) to your 

dataset(s). 

You have successfully located the path to your dataset. 

Version 14 (2008) or Above Vista or Windows 7 

Open "My Computer" and unhide hidden folders by going to Tools>Folder Options>View>Hidden 

Files and Folders>Show hidden files and folders>OK 

Next go into your C: > Documents and Settings > All Users > Application Data > Sage > Accounts > 

(The year number of your version e.g. 2009 for V15). 

Here you will find a file called "Company" it has no file extension so has no icon associated with it 

and looks "strange" 

Double click it - You will be asked what application you want to use to open the file, (the exact 

dialogue varies from operating system to operating system - but you should be able to work it out) 

choose NOTEPAD do not choose anything else. 

When the file opens you will find it contains one or more lines of text giving the path(s) to your 

dataset(s) 

You have successfully located the path to your dataset. 
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Autotask API URL’s 
The current variations for the API URL (version 1.5) are: 

 North America: https://webservices.autotask.net/atservices/1.5/atws.asmx  

 London Data Centre: https://webservices4.autotask.net/atservices/1.5/atws.asmx  (Formerly 

Global 1) 

 Limited Release:  https://webservices1.autotask.net/atservices/1.5/atws.asmx  

Autotask anticipates the regular release of new versions of the Web Service API. Although new 

versions will, for the most part, support backward compatibility through multiple releases, there 

may be changes to functionality that have an impact on AT2Sage.  

Please report any issues to Smart IT Support for repair. 

 

https://webservices.autotask.net/atservices/1.5/atws.asmx
https://webservices4.autotask.net/atservices/1.5/atws.asmx
https://webservices1.autotask.net/atservices/1.5/atws.asmx
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End User License Agreement 
This EULA governs the relationship between You and Smart IT Support Limited ("Smart IT") concerning Your use of Smart IT’s front-end 

software ("the Software") which You have obtained or use the relevant Smart IT Licensee (the "Licensee").  

 

If You have not already done so, please review the Terms and Conditions and Privacy Policies on the Licensee’s website, which govern the 

relationship between You and the Licensee. Links to the Licensee’s Terms and Conditions and Privacy Policies are provided on the 

Licensee’s account registration pages, where personal information is required for account creation.  

 

By accepting this EULA and by using the Software, You agree to be bound by the terms of the EULA and consent to the installation, storage 

of settings, automatic update and network activity set out in clause 2.  

Licence 

Smart IT grants You a licence to download, install and use the Software to copy invoice data from Autotask to Sage offered by the 

Licensee. You may also copy the Software for this purpose. Any other use or copying of the Software is prohibited. 

The Software and all rights in the Software remain the property of Smart IT. You must not copy, decompile, reverse engineer, disassemble 

or otherwise attempt to access the source code or object code of the Software, nor modify, adapt, or translate the Software, or otherwise 

do anything to or with the Software that is not strictly required for normal licensed use. The architecture and code of the Software is a 

valuable trade secret of Smart IT, and You undertake not to disclose any information relating to the architecture or code that You may 

discover from downloading or use of the Software. 

You have no transferable rights in the Software. In particular, You are not permitted to sub-license or rent out the Software, assign or 

otherwise dispose of the Software in any manner nor attempt to do so. 

Installation, storage of settings, automatic update and network activity 

Installation and/or use of the Software will result in files and content being downloaded and/or updated from an installation and update 

server and being stored on your disk. This happens as a transparent background process under the following circumstances: a) during first 

time installation of the Software; b) each time You start the Software; and c) after You have started up the Software in order to deliver 

new updates or content. Registry entries will also be created or updated in Your computer’s registry. 

Smart IT may use industry-standard methods (such as registry entries) to store information (such as Your user name, software settings and 

session information) on your disk. Such methods and information are strictly necessary in order for You to use the software offered by the 

Licensee. You may elect to save your password. Doing so will save You time as You will not be required to re-enter it each time You use the 

Software. Your password will be saved in the registry and to a xml file of Your computer in encrypted form. 

During Your use of the Software, the Software will communicate with Smart IT registration servers and Autotask servers that are operated 

by or on behalf of the Licensee, and Autotask. Such communication is necessary for You to be able to use the software and to verify 

registration by the Licensee using the Software and for the Licensee to maintain Your user account. 

Smart IT will collect some generic information about the computer hardware You are using to run the Software. None of this information is 

personal information and it is not used to identify any person. 

Limitation of Liability 

In no event will Smart IT be liable to You nor any third party in contract, tort, negligence or otherwise for any consequential, direct, 

indirect, pure economic or incidental damages, nor any lost profits or lost savings, arising out of Your or any third party’s access to, or use 

of, the Software, even if a Smart IT representative has been advised of the possibility of such loss. 

Smart IT does not warrant that Your use of the Software will be uninterrupted or error free. 

Nothing in this paragraph 3 shall exclude or limit: 

the liability of Smart IT for death or personal injury arising from the negligence of Smart IT or any of its officers, employees or agents; or 

any other liability which Smart IT is prohibited from excluding or limiting, as the case may be, by law. 

General 

If any part of this EULA is found to be invalid, void, or unenforceable, then the remainder of the EULA shall remain in force. 

This licence shall be governed by English Law and the courts of England shall have exclusive jurisdiction over all disputes arising in 

connection with this EULA. 


